avatar

Ошибка upstream timed out в Nginx + (70007)The timeout specified has expired

часто появляются ошибки при продолжительном выполнении скрипта
ошибки Nginx
upstream timed out (110: Connection timed out) while reading response header from upstream

и ошибки Apache
(70007)The timeout specified has expired: [client 127.0.0.1:39850] AH01075: Error dispatching request to : (polling),
Рейтинг 4.2 из 5. Голосов: 3047
Krasavica 1 месяц назад
4
,

0


Ответы (4)

Krasavica
Ukraine,Odessa
avatar
За 6 месяцев на форуме За год на форуме За два года на форуме за 10 сообщений За 100 сообщений
Сообщений : 236
на форуме с: Dec 13
Репутация:0
1 месяц назад
три слабых звена для которых необходимо увеличить время ожидания в настройках

во первых время выполения самого пхп срипта
CODE:
ini_set( max_execution_time , 6000) //sec


во вторых в апаче
/etc/apache2/apache2.conf
CODE:
#
# Timeout: The number of seconds before receives and sends time out.
#
Timeout 3000



в третих в нжине

Nginx в качестве proxy или reverse proxy
CODE:
location / {
...
proxy_send_timeout 150m
proxy_read_timeout 150m

client_header_timeout 200m
client_body_timeout 200m
send_timeout 200m
...
}


Nginx с подключенными FastCGI-серверами

CODE:
location ~* .php$ {
include fastcgi_params
...
fastcgi_read_timeout 150
...
}
отправить
+ 0

Krasavica
Ukraine,Odessa
avatar
За 6 месяцев на форуме За год на форуме За два года на форуме за 10 сообщений За 100 сообщений
Сообщений : 236
на форуме с: Dec 13
Репутация:0
1 месяц назад
примерно так работает нжин для php через fastCGI
примерно так работает нжин для php через fastCGI
отправить
+ 0

Krasavica
Ukraine,Odessa
avatar
За 6 месяцев на форуме За год на форуме За два года на форуме за 10 сообщений За 100 сообщений
Сообщений : 236
на форуме с: Dec 13
Репутация:0
1 месяц назад
спасибо увеличили время, всеравно тайаут

(32)
Broken pipe:
[client 127.0.0.1:35144]
AH01075: Error dispatching request to : (passing brigade to output filters),
referer:....
отправить
+ 0

Krasavica
Ukraine,Odessa
avatar
За 6 месяцев на форуме За год на форуме За два года на форуме за 10 сообщений За 100 сообщений
Сообщений : 236
на форуме с: Dec 13
Репутация:0
1 месяц назад
проверьте конфиги апача
CODE:
IfModule mod_proxy.c

ProxyTimeout 900

Proxy fcgi://127.0.0.1:9000
ProxySet connectiontimeout=5 timeout=900 retry=3
/Proxy

/IfModule


или
/etc/apache2/conf-enabled/php7.0-fpm.conf
CODE:

# Redirect to local php-fpm if mod_php is not available
# IfModule !mod_php7.c
# Enable http authorization headers
SetEnvIfNoCase ^Authorization$ (.+) HTTP_AUTHORIZATION=$1
ProxyTimeout 9000
FilesMatch .+ .ph(p[3457]?|t|tml)$
SetHandler proxy:unix:/run/php/php7.0-fpm.sock|fcgi://localhost
/FilesMatch
FilesMatch .+ .phps$
# Deny access to raw php sources by default
# To re-enable it s recommended to enable access to the files
# only in specific virtual host or directory
Require all denied
/FilesMatch
# Deny access to files without filename (e.g. .php )
FilesMatch ^ .ph(p[3457]?|t|tml|ps)$
Require all denied
/FilesMatch
# /IfModule

отправить
+ 0


Чтобы оставить комментарий войдите или зарегистрируйтесь